Friday, December 14, 2012

Switching short notes

1)      Etherchannal
Interface Port-channal : Eg. Int port-channel 100
check cmd – show etherchannel brief
Switch> config t
Switch ( fa0/0 ) channel group 100
Switch ( fa0/1 ) channel group 100
Switch ( fa0/0 ) channel group 100
Switch ( fa0/1 ) channel group 100
 Mode – 5 types ( active, passive,auto, desire )
Switch ( fa0/0 ) # channel-group-number mode auto
Switch (fa0/1)# # channel-group-number mode desire
Saving -> copy running-config startup-config
Layer 2
Switch# configure terminal
Switch(config)# interface range gigabitethernet0/4 -5
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode desirable
Switch(config-if-range)# end
Layer 3
Switch# configure terminal
Switch(config)# interface port-channel 5
Switch(config-if)# no switchport
Switch(config-if)# ip address 172.10.20.10 255.255.255.0
Switch(config-if)# end
  
Physical Interface:
Switch# configure terminal
Switch(config)# interface range gigabitethernet0/4 -5
Switch(config-if-range)# no ip address
Switch(config-if-range)# channel-group 5 mode desirable
Switch(config-if-range)# end

Benefit  of using Etherchannal
1)      Increased Bandwidth
2)      Provide Redundancy
3)      Load balance Traffic

PAgP and LACP Interaction with Other Features
 PAgP is defined by  Cisco Protocol and LACP is  defined by  IEEE 802.3 AD
The Port Aggregation Protocol (PAgP) and Link Aggregation Control Protocol (LACP) facilitate the automatic creation of EtherChannels by exchanging packets between Ethernet interfaces. PAgP is a Cisco-proprietary protocol that can be run only on Cisco switches and on those switches licensed by licensed vendors to support PAgP. LACP is defined in IEEE 802.3AD and allows Cisco switches to manage Ethernet channels between switches that conform to the 802.3AD protocol.
The Dynamic Trunking Protocol (DTP) and Cisco Discovery Protocol (CDP) send and receive packets over the physical interfaces in the EtherChannel. Trunk ports send and receive PAgP and LACP protocol data units (PDUs) on the lowest numbered VLAN.
Spanning tree sends packets over the first interface in the EtherChannel.
The MAC address of a Layer 3 EtherChannel is the MAC address of the first interface in the port-channel.
PAgP sends and receives PAgP PDUs only from interfaces that have PAgP enabled for the auto or desirable mode. LACP sends and receives LACP PDUs only from interfaces that have LACP enabled for the active or passive mode
 Command
Description
show etherchannel [channel-group-number] {brief | detail | load-balance | port | port-channel | summary}
Displays EtherChannel information in a brief, detailed, and one-line summary form. Also displays the load-balance or frame-distribution scheme, port, and port-channel information.
show pagp [channel-group-number] {counters | internal | neighbor}1
Displays PAgP information such as traffic information, the internal PAgP configuration, and neighbor information.
show lacp [channel-group-number] {counters | internal | neighbor}2
Displays LACP information such as traffic information, the internal PAgP configuration, and neighbor information.
Distribution Switches ( 4507 )
VTP-VLAN Trunking Protocol (VTP) is a Cisco proprietary protocol that propagates the definition of Virtual Local Area Networks (VLAN) on the whole local area network. VTP carries VLAN information to all the switches in a VTP domain.
VTP- VTP domain domain-name
VTP mode
VTP password mypassword
cmd to check - show vtp status, show vtp password, show vtp password

Switch(config)# vtp domain eng_group
Setting VTP domain name to eng_group.
Switch(config)# vtp mode server
Setting device to VTP Server mode for VLANS.
Switch(config)# vtp password mypassword -à Setting device VLAN database password to mypassword.
Switch(config)# end
 
Vlan info carry ရန္ dmain name & password တူရမယ္
 
STP,RSTP ( Spanning Tree Protocol, Rapid STP )
switch(config)# spanning-tree mode rapid-pvst
 
The 802.1D is defined in these five different port states:
1.       disabled
2.       listening
3.       learning
4.       blocking
5.       forwarding
RSTP (802.1w) Port State
Is Port Included in Active Topology?
Is Port Learning MAC Addresses?
Disabled
Discarding
No
No
Blocking
Discarding
No
No
Listening
Discarding
Yes
No
Learning
Learning
Yes
Yes
Forwarding
Forwarding
Yes
Yes

 
 
VLANs & Trunking
VLAN config
(global) interface type port
(interface) switchport access vlan number
cmd check - show interface status
switchport access vlan 90
switchport mode access
spanning tree portfast
spanning tree guard root à Access Level switch

Trunk Config
switchport mode trunk
switchport trunk allow vlan 90,vlan 100,vlan 200

Static route- ip route 0.0.0.0 0.0.0.0 next hope

SVI ( Switch Virtual Interface )-Layer3 မွာလုပ္တယ္ act as a gateway

#interface vlan Number
A switch virtual interface (SVI) is a VLAN of switch ports represented by one interface to a routing or bridging system. There is no physical interface for the VLAN and the SVI provides the Layer 3 processing for packets from all switch ports associated with the VLAN.
There is one-to-one mapping between a VLAN and SVI, thus only a single SVI can be mapped to a VLAN. In default setting, an SVI is created for the default VLAN (VLAN1) to permit remote switch administration. An SVI cannot be activated unless associated with a physical port.
SVIs are generally configured for a VLAN for the following reasons:
  • Allow traffic to be routed between VLANs by providing a default gateway for the VLAN.
  • Provide fallback bridging (if required for non-routable protocols).
  • Provide Layer 3 IP connectivity to the switch.
  • Support bridging configurations and routing protocol.
Layer 3 Switch ေတြမွာ ဘယ္ slot နံပါတ္၀င္ခ်င္ရင္
Session Slot Processor 1